By using AWS re:Post, you agree to the Terms of Use

AWS CLI not supported

0

Hello everyone,

I can not run the below command .. any help ??

*aws ivs put-metadata --channel-arn <your-channel-arn> --metadata <your-metadata>

I tried to write "aws ivs help" but got an error ....


irfan@irfan-Lenovo:$ aws --version
aws-cli/2.0.30 Python/3.7.3 Linux/5.4.0-58-generic botocore/2.0.0dev34
irfan@irfan-Lenovo:
$ aws ivs help
usage: aws [options] <command> <subcommand> [<subcommand> ...] [parameters]
To see help text, you can run:

aws help
aws <command> help
aws <command> <subcommand> help
aws: error: argument command: Invalid choice, valid choices are:

accessanalyzer | acm
acm-pca | alexaforbusiness
amplify | apigateway

Edited by: irfanKhan on Feb 9, 2021 9:13 AM

Edited by: irfanKhan on Feb 9, 2021 9:13 AM

asked 2 years ago162 views
3 Answers
0

Please ensure you are using an updated version of the AWS CLI https://docs.aws.amazon.com/cli/latest/userguide/install-cliv2.html Amazon IVS was added to the AWS CLI in version 2.0.31, so a version of 2.0.31 or newer will be needed to use IVS through the AWS CLI.

answered 2 years ago
0

thank you /... problem is solved .. i updated aws CLI

answered 2 years ago
0

thas to aws team .. problem is solved ..
AWS CLI update was required ...

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions