ACM DNS certificate validation. CNAME name/value undefined.



I'm trying to create a certificate for my domain under ACM. It's currently stuck in Pending Validation. I need to create CNAME DNS records to complete validation. However, the "CNAME name" and "CNAME value" columns are both blank. If I click the copy button, and paste the value in a text editor I get the "undefined".

I tried deleting the certificate, and then re-creating, I get the same problem.

I also tried clicking Create Records in Route 53. On the next page, the "CNAME name" and "CNAME value" are also blank. When I click Create Records, nothing happens.

How do I complete DNS certificate validation?



asked 3 months ago200 views
1 Answer
Accepted Answer

I now see the CNAME name/value pairs. It took somewhere between 20 and 40 minutes to populate in the UI.

answered 3 months ago
profile picture
reviewed 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions