Cognito UI does not show error when User Pool is not enabled.

1

We are currently using Cognito for the user management and using its hosted UI to let users' login to our application. As we want only allow certain users from our customers to access the application, we redirect the users to the customer's Identity provider portal based on the email provided by the user to authenticate them via SAML. For example, user with email id sam@google.com would enter his email address in the corporate email input box and he would be redirected to the external Identity provider to be authenticated. The issue here is if the user mistypes the domain name or if the domain entered is not registered with Cognito before the user is redirected to the same Cognito page with error in the url but the error is not shown to the user on the UI itself. As this is a bad experience from user point of view we are trying to understand if this a known issue with Cognito or we could fix with a config change somewhere? If we enable the Cognito User Pool as one of the identity providers then we are able to see the error in the UI but we have no plans to enable User Pool as provider.

asked a year ago252 views
2 Answers
2

Use the 'PreventUserExistenceErrors' setting of a user pool app client to enable or disable user existence related errors.

More details in the docs link below https://docs.aws.amazon.com/cognito/latest/developerguide/cognito-user-pool-managing-errors.html

answered a year ago
  • This is already enabled but it doesnt solve the problem.

0

Hello nikhilaws, has your issue been resolved? . If so, please remember to click on the "Accept" button to let the community know that your question is resolved. This helps everyone. Thank you in advance.

profile picture
SUPPORT ENGINEER
answered 10 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions