By using AWS re:Post, you agree to the Terms of Use

Sharing file with URL link in S3

0

I have worked with S3 for a couple of years, and was familiar with the old buckets...and how to share files publicly. However recently when I created a new bucket, I have not been able to share a file to the public the way I had done it in the past. When setting up the bucket and file, I have unchecked the "block public access" however it is not allowing the URL link to work...it says access denied. Can someone please explain what else I need to do in the file/bucket to allow this?

2 Answers
1

Hi! There have been a few updates to S3 recently that could explain the behavior you're seeing.

  • Ensure Block Public Access Settings are off at the account level and the bucket level.
  • If the object is already stored, you may need to update the object ACL either through console or CLI (aws s3api put-object-acl --bucket <bucket-name> --key <object-key> --acl public-read.
  • Optionally, you could use a bucket policy as well.

Lastly - a friendly reminder to be careful with S3 public settings and public permissions as it's recommended to have this locked down and secured unless absolutely necessary to have files public. Then, if files need to be public, be careful with adjacent buckets in the account, even folders/etc within the same bucket, and even only giving out the necessary permissions to read the object (and not describe metadata).

answered 8 months ago
  • I have the public access settings turned off but it is still not granting access to the public. Can you explain more on the ACL settings to allow public access please?

0

For easy S3 file/folder sharing and collaboration with external users using advanced SSO, please check NirvaShare - https://nirvashare.com

answered 4 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions