3 Answers
- Newest
- Most votes
- Most comments
1
Me too -- trying to execute the query from a lambda fails with "unknown error". The athena, s3, and glue clients are all instantiated with an access token belonging to a root admin.
Retrying the query from AWS console simply works...
answered 3 years ago
-1
I haven't heard back yet, but this morning my team is not having this issue with Delta Tables on Athena anymore.
answered 3 years ago
You are right, worked on my side as well. Thanks.
Relevant content
asked 3 years ago
asked 3 years ago
- AWS OFFICIALUpdated 2 years ago
- AWS OFFICIALUpdated 2 months ago

Facing exactly the same problem, starting today.
I also started suddenly having troubles with delta tables on Nov 3rd. I became unable to make new tables, but old ones stayed functional. If I drop the old tables and make a new one to the same table in S3, it will stop working despite the table not changing. Wondering if anyone has any updates on this? Working in us-east-1
I have the same problem on us-east-1. Changing to us-east-2 I had no problems creating new tables or performing a show create table
I am having the exact same issue. We can't create new delta tables or generate DDL on existing ones. Opened a support case and was told the Athena team is aware this is an issue.