By using AWS re:Post, you agree to the Terms of Use

Cannot create AWS Workspace using Amazon Linux 2 (but can create using Windows image)

1
  1. Create new workspace using the Amazon Linux 2 bundle
  2. Workspace fails to load with "There was an error creating the WorkSpace. Retry the request. If the problem persists, contact AWS support."

We were able to successfully do this same process a couple of months ago when we last tried it.

2 Answers
0

Unfortunately there's not a lot of information to go on here; as per the error message please contact AWS support.

profile picture
EXPERT
answered 8 months ago
0

I'm having this exact same issue. I have a Microsoft Managed AD directory setup with Windows workspaces provisioned just fine. When I try to provision a Linux 2 bundle, it fails instantly with the same error message. The workspace is in pending mode for 25 mins and transitions into Error state without much information other than "contact AWS support or post on AWS forums".

I have considered the issue with the EBS KMS key used to encrypt both root and user volumes. I have ensured that 1) My IAM user has all the required permissions to use the KMS key for EBS encryption 2) The resource policy on the EBS KMS key allows my IAM user access to use the key for encryption, decryption, and generating data keys as noted in this AWS support article (https://docs.aws.amazon.com/workspaces/latest/adminguide/encrypt-workspaces.html#kms-workspaces-permissions).

I tried provisioning a workspace with unencrypted root and user volumes and got the same result.

Looking at CloudTrail's logs for the event name "DescribeWorkspaces" to see the status of the workspaces listed, I see the following:

{
                "bundleId": "wsb-xxxx",
                "workspaceId": "ws-xxx",
                "rootVolumeEncryptionKey": "arn:aws:kms:eu-west-1:xxxx:key/xxxxx",
                "directoryId": "d-xxxx",
                "state": "ERROR",
                "errorCode": "Internal.ServerError",
                "userName": "xxxx",
                "userRealm": "xxxx",
                "workspaceProperties": {
                    "recycleMode": "DISABLED",
                    "userVolumeSizeGib": 10,
                    "runningMode": "AUTO_STOP",
                    "computeTypeName": "STANDARD",
                    "rootVolumeSizeGib": 80,
                    "runningModeAutoStopTimeoutInMinutes": 60
                },
                "userVolumeEncryptionKey": "arn:aws:kms:eu-west-1:xxxx:key/xxxx",
                "errorMessage": "There was an error creating the WorkSpace. Retry the request. If the problem persists, contact AWS support.",
                "volumeEncryptionKey": "arn:aws:kms:eu-west-1:xxxx:key/xxxx",
                "rootVolumeEncryptionEnabled": true,
                "modificationStates": [],
                "userVolumeEncryptionEnabled": true
            },

I also considered the workspace quotas. I currently have 8 workspaces in total (including the workspace in error state) with a quota limit of 50.

I hope someone from the AWS Workspace team will be able to shed some light on this issue as I do not have AWS premium support.

answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions