By using AWS re:Post, you agree to the Terms of Use

SAM & Docker Builds-- How do they update (not working for me)?

0

TLDR' Sam deploy for docker images not recognizing changes to Dockerfile or app.py.

Using this terrific blog post--> https://aws.amazon.com/blogs/compute/using-container-image-support-for-aws-lambda-with-aws-sam/ , I've built an image with an NLP framework and pushed to ECR then accessed from another lambda. No problem.

When I go to the Dockerfile and the app.py to make changes and expand the text analysis functions I am trying to use, sam deploy says no changes to be deployed.

I've tried:

  1. sam validate && sam build && sam deploy
  2. sam validate && sam build && sam deploy --guided (repeatedly)
  3. sam validate && sam build && sam deploy --force-uploads
  4. Removed "cache=true" from the samconfig.toml and tried again

In the past, I've done manual docker pushes and worked with Dokku/Docker so I am not completely ignorant of the process. But this is odd behavior. I read someplace else lambdas connected to docker images don't reset for the "latest" image version. What am I missing?

1 Answer
0

For time being, I copied the original lambda function with another name and image tag. Deploying correctly.

answered 7 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions