AWS Amplify/Appsync - Added a table to the schema, but api not updated


Hi I have added an additional table to schema.graphql and run amplify publish. The table has been created but I am not seeing new methods in the mutations.js/queries.js/subscriptions.js files to reflect the new table. This is a vue js app. Is there any other command I need to run to update the local sources?


2 Answers

Hi Alatech

Thanks for your suggestion. I tried amplify push (which I think just pushes the backend) and then tried publish (I think pushes back and frontend?). Anyway, if I now do an 'amplify status' it returns that there are no changes in any of the Auth, Api or Hosting (the 3 amplify services I am using). If I do an 'amplify push' it simply returns with 'no changes detected' and returns. I have edited the schema a few times and tried push and publish and the files in /graphql/amplify are not being updated to reflect the new table. They have code to reflect the existing tables I have created.

answered a year ago
  • That is odd.

    Can you try to update the api amplify update api

    and then select GraphQL and Disable Conflict Detection as see if helps?

  • Hi Alatech Looks like conflict detection is already off. I ran the command and it provides the status:

    Conflict detection (required for DataStore)

    • Disabled

    I will post a support query with AWS and update this post if/when I get a resolution



You can try with amplify push.

Modify the resources and even before deployment, it should show all resources that are going to be updated and Unchnged ones.

Hope it helps

profile picture
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions