docker login on ecr not responding

4

I have a CI pipeline that require to do a docker login for a private ecr registry. But this step is now blocking for many hours. This step worked many time before. The problem started around 10th November 13H +01 UTC in region eu-west-1. I've tried to generate a token with aws ecr get-login-password and a docker login on the registry manually but i have the same result. If i do a telnet to registry, it's responding. Connectivity is ok.

  • what is the exact error?

  • there is no error message, just blocking undefinitely

  • we have the same here. context is : we are logging in from github action CI to ECR to push fresh built image. It worked last week and on thursday it started to hang indefinetly our CI with no error information / stack traces. We changed nothing on our credentials and architecture around ECR last week. We tried a telnet sucessfully to ECR, but it does not work from aws cli (hang indefinetly). What's more, cloud trail shows a successful connection attempt from our CI to ECR before hanging. Note: we work on AWS Ireland.

  • Same there, looks like and AWS internal issue not show on AWS Health monitor.

asked 2 years ago936 views
1 Answer
1
AWS
answered 2 years ago
profile picture
EXPERT
GK
reviewed 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions