By using AWS re:Post, you agree to the Terms of Use
/Can't install iam-authenticator in cloudshell/

Can't install iam-authenticator in cloudshell

0

I want to install iam athenticator in a cloudshell environment, but I keep getting an error when I run the following command.

curl -o aws-iam-authenticator https://s3.us-west-2.amazonaws.com/amazon-eks/1.21.2/2021-07-05/bin/linux/amd64/aws-iam-authenticator

It returns this error.

Warning: Failed to create the file aws-iam-authenticator: Permission denied

I'm following a tutorial and I'm not sure why I get the above error and I cannot continue the tutorial without iam_authenticator installed.

1 Answers
2
Accepted Answer

The command above is to download the file named "aws-iam-authenticator" from the URL and then save it into the current directory under the same file name at your local machine / server. And the error message here show that your account currently have no permission to save the file on that directory

answered 14 days ago
  • That was it!

    For some reason none of the directories were visible when I first logged in and used 'pwd', but once I did 'cd ./bin', I could see everything in that directory. Once I went back using 'cd ..' I could see the directories in that directory too. Strange.

    The Sudo command worked as well and I am running!

    Thank you.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions