Launch test instance for MGN conversion fails with "Conversion failed"

0

Hello, I'm using MGN to migrate a Windows 2016 64 bit with 2 disks (each ~232 GB). The migration dashboard shows that the initial replication finished and that it's "ready for testing." However, when I try to launch a test instance, the conversion starts, but fails a few minutes later. The job log (under Launch history > Job:mgnjob...) doesn't provide a lot of context, the only feedback is "Conversion failed". I've tried launching test instances multiple times, all with the same result. In an attempt to get a little bit more data as to what's going on, I can view the system log for the converter instance as the conversion is progressing. I've included relevant snippets of the system log below. I'd appreciate any recommendations anyone can offer in terms of next steps for troubleshooting why the conversion is failing.

Included below are some snippets of the system log.

Start of the log:


2022/06/21 17:17:34Z: Windows sysprep configuration complete.

2022/06/21 17:17:36Z: Message: Waiting for meta-data accessibility...

2022/06/21 17:17:36Z: Message: Meta-data is now available.

2022/06/21 17:17:38Z: AMI Origin Version: 2022.06.15

2022/06/21 17:17:38Z: AMI Origin Name: Windows_Server-2016-English-Full-Base

2022/06/21 17:17:38Z: OS: Microsoft Windows NT 10.0

2022/06/21 17:17:38Z: OsProductName: Windows Server 2016 Datacenter

2022/06/21 17:17:38Z: OsInstallOption: Full

2022/06/21 17:17:38Z: OsVersion: 10.0

2022/06/21 17:17:38Z: OsBuildLabEx: 14393.5192.amd64fre.rs1_release.220610-1622

2022/06/21 17:17:38Z: OsCurrentBuild: 14393

2022/06/21 17:17:38Z: OsReleaseId: 1607

2022/06/21 17:17:38Z: Language: en-US

2022/06/21 17:17:38Z: TimeZone: Coordinated Universal Time

2022/06/21 17:17:38Z: Offset: UTC 00:00:00

2022/06/21 17:17:38Z: AMI-ID:

2022/06/21 17:17:38Z: Instance-ID:

2022/06/21 17:17:38Z: Instance Type: m4.large

2022/06/21 17:17:56Z: Driver: AWS PV Driver Package v8.4.2

2022/06/21 17:17:56Z: Driver: Intel(R) 82599 Virtual Function v2.1.186.0

2022/06/21 17:17:57Z: Launch: EC2 Launch v1.3.2003639

2022/06/21 17:17:57Z: SSM: Amazon SSM Agent v3.1.1188.0

2022/06/21 17:17:57Z: RDPCERTIFICATE-SUBJECTNAME:

2022/06/21 17:17:57Z: RDPCERTIFICATE-THUMBPRINT:

2022/06/21 17:18:10Z: HibernationEnabled: false

2022/06/21 17:18:14Z: Message: Windows is Ready to use

2022/06/21 17:18:15Z: EC2LaunchTelemetry: IsTelemetryEnabled=true

2022/06/21 17:18:15Z: EC2LaunchTelemetry: IsAgentScheduledPerBoot=false

2022/06/21 17:18:15Z: EC2LaunchTelemetry: IsUserDataScheduledPerBoot=true

2022/06/21 17:18:15Z: EC2LaunchTelemetry: AgentCommandErrorCode=1

2022/06/21 17:18:56Z: MGN script started

2022/06/21 17:19:26Z: 2022/06/21 17:18:55Z: ACPI SPCR table not found. Bailing Out

2022/06/21 17:19:26Z: 2022/06/21 17:18:55Z: Opening port (COM1) handle to write to the console

2022/06/21 17:19:26Z: 2022/06/21 17:18:56Z: MGN script started

2022/06/21 17:19:26Z: Directory: C:\

2022/06/21 17:19:26Z: Mode LastWriteTime Length Name

2022/06/21 17:19:26Z: ---- ------------- ------ ----

2022/06/21 17:19:26Z: d----- 6/21/2022 5:18 PM CloudEndure


Following that are some HTTP get requests that I will exclude since I believe the query parameters may include some sensitive information.

Next a series of "getting next command with token" in the log:


Starting running http commands.

run_commands started

client_config threads have spawned

getting next command with token 3a44cf0cb475650494ed7aa694017179

command received

getting next command with token 142f6916cb537e313e48eb1c9c6e92f7

command received


The last part of the log before the conversion fails is interesting. It references two services: UmRdpService and TermService. These are the Windows services for "Remote Desktop Service" and "Remote Desktop Services UserMode Port Redirector." So it appears that the conversion process has some issues with these two services, but that's as much as I've been able to glean.


Failed running all commands : None

2022/06/21 17:22:03Z: http_commands_client.exe returned:

SERVICE_NAME: UmRdpService

    TYPE               : 20  WIN32_SHARE_PROCESS  

    STATE              : 3  STOP_PENDING 

                            (NOT_STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)

    WIN32_EXIT_CODE    : 0  (0x0)

    SERVICE_EXIT_CODE  : 0  (0x0)

    CHECKPOINT         : 0x116

    WAIT_HINT          : 0x0

SERVICE_NAME: TermService

    TYPE               : 20  WIN32_SHARE_PROCESS  

    STATE              : 3  STOP_PENDING 

                            (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)

    WIN32_EXIT_CODE    : 0  (0x0)

    SERVICE_EXIT_CODE  : 0  (0x0)

    CHECKPOINT         : 0x1
    
    WAIT_HINT          : 0xea60

2022/06/21 17:22:03Z: MGN script finished


asked 5 months ago66 views
No Answers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions