Unable to create/select existing Security groups while launching DB instanc

0

I am trying to launch a MySQL DB instance.

I had created the Security group for my RDS instances before I launched them as I wanted to attach the existing SG to multiple instances. But the existing SG does not show up in the section while launching the DB instances.

I contacted the support. Since I do not have premium support, the agent had reached out to an engineer and told me to create a new SG while launching, which I am also unable to do since there is no option to create a new one while launching.

I have made sure that SGs and instance I am trying to launch are in the same region and same VPC. Since I am new to AWS, I am unable to figure out what the issue might be. I have also attached the screenshots below.

Thanks in advance

asked 4 years ago248 views
3 Answers
0

It seems that there is a bug in the new RDS creation console (I have just tested here I got the same behavior), you can change back to classic just changing the lw=classic attribute in the URL, as below:

<https://ap-south-1.console.aws.amazon.com/rds/home?region=ap-south-1&lw=classic#launch-dbinstance:gdb=false;s3-import=false >

Let me know if it works.

And in the classic RDS console you can create a new SG during RDS creation too.

Zacca
answered 4 years ago
0

Hey,

Thanks for looking into this. Yes, the older version of the console allowed to create/choose from existing SG options enabled and worked fine.

Will you please let me know how you changed it back to the previous version? In EC2, there is switch in the left to change the console version. Wasnt able to find something similar in RDS console.

Thank you in advance

answered 4 years ago
0

For me in RDS Console page there is a blue banner in the top of the page with a link to switch between both types.

If it's not the case for you, maybe you have closed the banner in the X and it does not appear anymore.

But if you add "&lw=classic" to the URL, it works the same way. And "&lw=single-page" switches back to the new interface.

I hope it solved the issue.

Zacca
answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions