Not able to detach EBS Volume

0

Although the EBS volume is not attached to any EC2 instsances, it is still showing in-use. I tried force detach from aws console but it is stuck. Force detaching the volume from AWS CLI shows following error

An error occurred (InvalidParameterValue) when calling the DetachVolume operation: The volume ID 'vol-00402f84342cf78f' is malformed
asked 2 years ago506 views
3 Answers
0

The error message is clear - that the volume id you're passing isn't formatted correctly. Looking at a volume id that I have, it appears that yours is missing a character. Can you check and make sure it is the right volume id?

That said: If it really is stuck, the best thing to do is to raise a support case. Here on re:Post we don't have access to your account details nor other personal information but the support team can help in these cases.

profile pictureAWS
EXPERT
answered 2 years ago
0
An error occurred (IncorrectState) when calling the DetachVolume operation: Volume 'vol-00402f84342cf78fa' is in the 'available' state.

Sorry about the wrong error message, this is the error I am getting. I am not able to detach the volume. This volume is not attached to any of the entity but still showing as available. Also, I tried detaching it via command line and AWS console, Below error message is from Command line and from AWS console, there is no error message but the process takes forever to complete.

answered 2 years ago
0

A volume in available state means it's not attached to an instance; its already detached. Deleting a volume and detaching a volume are two different actions. As long as an EBS volume exists either as available or in-use you incur EBS related charges.

profile picture
Syd
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions