Could not connect to the endpoint URL: ""


I am trying to run the command "aws s3 ls" and I'm getting the following response:

Could not connect to the endpoint URL: ""

I have verified that the credentials I have set up in my credentials file have programmatic access.
My config file is set up with the following values:
region = us-east-1
output = json

I have tried setting up a new user and creating new credentials.
I have tried uninstalling and reinstalling the cli.
Ping request could not find host
I did get a response from ping

Does anyone know what I am doing wrong or what else I can try?

asked 3 years ago1188 views
1 Answer

Just after I posted this I noticed that I had an environment variable set up causing the region to be set as "local".
I removed the AWS_DEFAULT_REGION environment variable and it is now connecting to the correct endpoint URL using the region from my config file.

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions