No Solution Stack named '64bit Amazon Linux 2 v3.1.2 running Go 1' found.

0

I was trying to run TheThingsNetwork quick start integration with AWS, and it fails to complete.
https://www.thethingsnetwork.org/docs/applications/aws/quick-start.html

The first error it fails on is:
No Solution Stack named '64bit Amazon Linux 2 v3.1.2 running Go 1' found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: 472190c0-7f96-48e3-9c4f-f5b046790d95; Proxy: null)

I've tried to figure out what valid Solution Stack versions are available but cant' find it listed anywhere. I tried to read the CloudFormation template to see if I could use it as a roadmap to manually create the Elastic Beanstalk application, but nothing matches up what I'm seeing in the template.

What's the best way to figure out/resolve this?

dnear1
asked 2 years ago528 views
1 Answer
0
Accepted Answer

So I believe the issue is in the template provided by TTN. If you scroll down in the template in the section under the header "TTNConfigurationTemplate:" they define "SolutionStackName" as "64bit Amazon Linux 2 v3.1.2 running Go 1." If you go into Elastic Beanstalk and try to manually create your own environment you'll see that the only option given by AWS is "64bit Amazon Linux 2 v3.1.1 running Go 1" and that no version 3.1.2 is available. You'll need to download the template and change v3.1.2 to v3.1.1 and then manually create the stack yourself.

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions