By using AWS re:Post, you agree to the Terms of Use

Elastic Beanstalk: Unable to access environment's Configuration. Error: A problem occurred while loading your page: Configuration validation exception:

0

I rarely log into the AWS console. I deploy using the CLI. I logged in recently to see my EB configuration and was redirected back to the applications page "Elastic Beanstalk > Applications" with the error:

Error

A problem occurred while loading your page: Configuration validation exception: Invalid option value: 'awseb-e-XXXXXXXX-stack-AWSEBSecurityGroup-XXXXXXXX’ (Namespace: 'aws:autoscaling:launchconfiguration', OptionName: 'SecurityGroups'): The security group 'awseb-e-XXXXXXXX-stack-AWSEBSecurityGroup-XXXXXXXX' does not exist

Prior to this error message I got a slightly different one referring to Launch Template referencing that security group. I created a version 2 of the launch template but used the UI to point to the correct security group. Now that error is gone and I see this new one in its place.

I have since redeployed the app, thinking it needed the new template to take effect. I have tried using eb config to change/update the template name and then redeploy but it didn't work.

Not sure what's changed or how to fix. Any help would be appreciated.

Update 1:

Just to be clear, the website is functioning correctly. Nothing is down. No errors, as far as I can tell, in the logs. This issue is only localized to "Elastic Beanstalk > Applications" page.

Update 2:

Per the suggestion to clone the environment, I tried but the error appears there too preventing me from proceeding. See image below.

Interestingly, I was able to create a brand new, clean, Elastic Beanstalk environment from scratch, but then when I tried to view its completely unrelated configuration I also got this error.

About the suggestion that perhaps I deleted something at some point, I think that's very doubtful because I don't tinker with my environment, I set it up once and then I leave it. I last touched it in January (6+ months ago) when I upgraded the Platform to AL2. There were no errors then and the only interaction with Elastic beanstalk prior to the upgrade and post upgrade is running my make file like so: make deploy_aws_production so I don't even work with the CLI really.

Enter image description here

1 Answers
0

Hey

Its sounds like the CloudFormation stack could be drifted. Is it possible the Security Group was deleted? It does not have to be via the UI but if its done outside the Beanstalk service (e.g. CLI delete-security-group) then we could expect to see this error.

Resolving some of the behaviour by changing the launch template via the EC2 UI should really not be required. Everything should be done within the scope of Beanstalk i.e the Beanstalk Configuration page in the UI, the eb cli or the API.

I would suggest cloning [1] the existing environment and confirming it has the same errors. Then rebuild the new environment [2] so that it will "restore it to a working state. Rebuilding an environment terminates all of its resources and replaces them with new resources with the same configuration." IF you confirm the new environment is working as expected you can then swap the CNAME URL records [3]

If this does not resolve the behaviour I would look to create a new environment with the desired platform and configuration. Deploy your application and swap the CNAME records.

  1. https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/using-features.managing.clone.html
  2. https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/environment-management-rebuild.html
  3. https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/using-features.CNAMESwap.html
profile picture
answered a month ago
  • Thank you for the help. I updated my question with the status of the website (tldr; it's fine, operating as expected, not down). Would your suggestion on how to fix this still be relevant if the website was operating as expected and the only issue is localized to the Elastic Beanstalk page?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions