Domain registered on route 53 not working

0

Hi, I have registered my domain in Route 53 to point to my instance in Lightsail. After trying a lot a things I did this to make it work but still not working: So i have created the DNS zone in Lightsail, put the same name servers in the route 53 configuration for the domain. Ive also, created an A record with dcprivateclub.com pointing to the static ip address where my instance is attached (i have attached the instance to that static ip address which is 54.147.170.148). I have checked and the https://dnschecker.org/#NS/dcprivateclub.com and the name servers are correct, and A type also poiting to my ip address. I cant understand what I am doing wrong and why is not working, is very frustrating so I would appreciate a help a lot. Thanks!

4 Answers
0

Hello.

I get a timeout error when I try to access a web page.
Follow the steps in the following document to make sure that Lightsail's firewall allows port 80 for HTTP.
https://lightsail.aws.amazon.com/ls/docs/en_us/articles/understanding-firewall-and-port-mappings-in-amazon-lightsail

If the Lightsail firewall is OK, also check the OS firewall settings.

profile picture
EXPERT
answered 8 months ago
  • IPv4 Firewall HTTP TCP 80 Any IPv4 address It seems that is OK. Any other ideas? thanks a lot for your help. When i try to enter through e temorary address that the developers who create the instance gave me, it works. http://54.147.170.148/plesk-site-preview/infallible-curie.54-197-152-197.plesk.page/https/172.26.15.173/login Maybe that help.

  • When you access the site, you will be redirected to the following domain. Perhaps the settings on the web server or in the application are incorrect. https://infallible-curie.54-197-152-197.plesk.page/

  • OK, i have just entered to the instance through ssh and check with nmap the open ports, 80 is not shown as open, i will try to open it now and will let you know. thanks a lot.

  • Well that was on the localhost. I have checked the private IP which is 172.26.15.173 and it is open.

  • So the developers are using Plesk and I am starting to think theres something wrong with their configuration as you suggested (which was also my suspicious at the begining). I will try to check all that. Thanks a lot.

0

Hello, I think the reason why your domain name cannot be accessed may be that the security group did not release the HTTP port. Check the security group's records to see if they have been released?

profile picture
shinya
answered 8 months ago
0

Please try stopping and then starting your instance. This in many cases helps update your plesk application configuration to the mapped Static IP correctly.

profile pictureAWS
MODERATOR
AWS-SUM
answered 8 months ago
  • I have tried that and not working. I am starting to suspect that i need to disable plesk dns settings in order for lightsail to take care of it.

  • Please note Reboot is different from Stop Instance + Start Instance. So please ensure you have tried the latter.

0

If there is no problem with the security group, you can take a look at the selinux configuration in the OS. Modify the selinux configuration file to disable it. I understand that it is because the path for the http service is not properly configured, which is causing the webpage to be inaccessible.

profile picture
shinya
answered 8 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions