AWS SES - Connection time-out on port 25

0

Hello,

Our AWS account ID is 592296619356. We have a Java based web-application running on an EC2 instance in Mumbai which sends emails through SMTP server at Ireland - email-smtp.eu-west-1.amazonaws.com , port 25 (because SES was not available in Mumbai when this account/application was set up).

The emails were going out fine till recently but now we cannot connect to the SMTP server at all and are getting connection timed out errors.

Exception: com.sun.mail.util.MailConnectException: Couldn't connect to host, port: email-smtp.eu-west-1.amazonaws.com, 25; timeout -1;

I tried all the troubleshooting tips at https://aws.amazon.com/premiumsupport/knowledge-center/smtp-connectivity-timeout-issues-ses/ and I am not able to telnet at all which suggested a network issue?

I tried by disabling firewall, adding outbound port 25 and inbound 1024-65535 in our security-group, network acl etc. but it is still unable to connect.
nmap shows that 25 is open on our ec2 and on the smtp server it shows as 25/tcp filtered smtp.

Could you please point me towards a solution to this issue? (Email is an integral part of our application registration/status etc. and without it a user cannot proceed).

Thanks a lot.

raghdr
asked 3 years ago179 views
3 Answers
0

For anybody still looking into this thread - I found some helpful tips at https://docs.aws.amazon.com/ses/latest/DeveloperGuide/Welcome.html
Changing the port to 587 and using explicit tls seems to have resolved the issue.

raghdr
answered 3 years ago
0

We also started to experience similar behavior. We were using port 465 though. This was happening to about 10% of outcoming mails.

We implemented a retry mechanism. If sending fails it will be tried again in 1 minute. This solved this issue (for now).

I've also tried to switch to port 587 - but the outcome is the same as on 465.

qunerd
answered 3 years ago
0

Hello did you ever get to the bottom of this? I'm suffering through the same issue here

answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions