Can't create CloudFront distribution with standard logging despite I'm the bucket owner

0

I'm trying to create a CloudFront distribution for a S3 website endpoint, using AWS Console (I've also tried Terraform but the output is the same).

I want to use standard logging, and for that I created a S3 bucket with Block all public access enabled. I'm the owner of said bucket.

As per the docs, I've also added ACL permissions for awslogsdelivery account. However, when I try to create the distribution, I receive the following error:

You do not have permission to use my-bucket.s3.amazonaws.com for standard logging. To use this bucket, the bucket's owner will need to create a FULL_CONTROL access control list (ACL) for your account. Once you have access, please try creating the distribution again. More information on ACLs can be found here .

The Object Ownership is set to Bucket owner preferred.

As I said, I'm the owner of the bucket so I don't really know what's going on here. Any ideas?

Thanks in advance

frand
asked 9 months ago264 views
1 Answer
0
Accepted Answer

I just changed the region of the bucket from eu-south-2 to eu-west-1 and it worked. Is this the expected behaviour?

frand
answered 9 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions