Systems Manager "advanced instances" stuck in pending state

0

I wanted to try out the "advanced instances" feature in Systems Manager, which is now a toggle on at the account level. That worked just fine, but there is nowhere in the console to toggle it off.

https://docs.aws.amazon.com/systems-manager/latest/userguide/systems-manager-managedinstances-advanced.html

I tried via clia with this command: aws ssm update-service-setting --setting-id arn:aws:ssm:us-east-2:XXXXXXXXXXX:servicesetting/ssm/managed-instance/activation-tier --setting-value standard
But, now if I get status it's stuck in a pending state for more then 24hours at this point. Here is the output. Does anyone know how to get it back to standard for the account?

{
"ServiceSetting": {
"SettingId": "/ssm/managed-instance/activation-tier",
"SettingValue": "advanced",
"LastModifiedDate": 1552956830.414,
"LastModifiedUser": "arn:aws:iam::XXXXXXXXXXX:user/redacted@email.com",
"ARN": "arn:aws:ssm:us-east-2:XXXXXXXXXXX:servicesetting/ssm/managed-instance/activation-tier",
"Status": "PendingUpdate"
}
}

Edited by: kleinberger on Mar 19, 2019 11:56 AM

asked 4 years ago58 views
3 Answers
0

Please contact AWS Support if you want to change back to the standard-instances tier.

Thank you
Varsha

answered 4 years ago
0

Thanks, hopefully this request doesn't require a formal support contract.

Case ID 5896814371

answered 4 years ago
0

This ended up needing support to do something on the backend to revert back to "Standard" Systems Manager for the Account. The cli input that I tried was stuck in a pending state for days until the support group made their change. They refunded the incurred charges, but hopefully this helps someone else avoid.

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions