VSCode no longer support for Amazon Linux 2

0

Following the recent update from VSCode v1.86, they will no longer support Linux distro with glibc <2.28 and libstdc++ < 3.4.25. Is there any plan from the AWS team to update this?

Dammy
asked 25 days ago256 views
2 Answers
1
Accepted Answer

Hello,

Lundi here, thank you for reaching out with your question,

I would like to mention that our internal teams are aware of the mentioned issue whereby Starting with version 1.86, Visual Studio Code will require a minimum GNU C Library (glibc) version of 2.28. AL2 ships with glibc version 2.26, and currently, Amazon Linux does not provide a path to upgrade this library in AL2.

On 2024-02-08, Microsoft released a new build 1.86.1 that will work with older versions of glibc. If you encounter any issues with 1.86.1, please comment here.

https://code.visualstudio.com/updates/v1_86

profile pictureAWS
SUPPORT ENGINEER
Lundi
answered 24 days ago
  • Thank you for this. The PM on the Git hub tread mentioned this and we have updated it. However, he also mentioned that this will be only for one year(https://github.com/microsoft/vscode/issues/203375#issuecomment-1927893504). This is a bit worrying as the main reason why we use AL2 is that currently, the tesseract OCR package is not support on AL2023 and we use this package in our SaaS app and unfortunately, we have not found a suitable substitute. What will you advise we do?

0

Hi Dammy

Thank you for the feedback, I'm tracking this issue further internally and will provide further updates once received on my end. You are more then welcome to open a support case and reference this post so that our team can track this internally as well.

profile pictureAWS
SUPPORT ENGINEER
Lundi
answered 24 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions