Kernel panic during EC2 launch


During deployment of new app version on new EC2 with template from AMI image I got following error:

[    1.670047] No filesystem could mount root, tried: 
[    1.670048] 
[    1.677170] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    1.685026] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.14.181-140.257.amzn2.x86_64 #1
[    1.692532] Hardware name: Amazon EC2 t3a.nano/, BIOS 1.0 10/16/2017

previously it was working like charm - I haven't change any AMI or template setting - just added new SSL certs to nginx

I found this troubleshooting article but cannot move with it since I cannot access instance terminal.

I've tried to boo new instance with add different kernel ID but got this error:

You cannot launch multiple AMIs with different virtualization styles at the same time.

I believed during AMI kernel has somehow changed and it causes problem - is it possible?

What can cause that issue and how to solve?

asked 2 years ago784 views
1 Answer

It is impossible to suggest any resolution with the data that you provided. I suspect that the issue is related to error in /etc/fstab file. There might be also an error in launch template for Disk1 and wrong device name Or the Snapshot / EBS volume is corrupted.

If you added nginx certs then obviously you updated AMI so I suspect there was an issue during new image building process.

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions