EC2 Spot instance request fails to apply IAM Profile



While using the AWS Console to create an EC2 Spot instance request, I fill in all the details and set an IAM instance profile but when the spot request is created in the instance details section the IAM role is empty and the EC2 instance launched also has an empty IAM role.

This issue did not happen the last time we launched a new Spot fleet request 24 days ago, so it seems like a new bug, can anyone confirm if the issue is present on their console also?

I have also tried doing it via CLI but again the IamInstanceProfile parameter in the json:

"IamInstanceProfile": { "Arn": "arn:aws:iam::xxx" }

is ignored when the spot fleet is created. There is no error in the history log for the spot fleet request regarding failure to apply IAM role, so im not sure what seems to be the problem?

Here is trusted entities for that IAM role

    "Version": "2012-10-17",
    "Statement": [
            "Sid": "",
            "Effect": "Allow",
            "Principal": {
                "Service": [
            "Action": "sts:AssumeRole"



asked 2 years ago223 views
1 Answer

Hello Wasim,

I was able to create new Spot instances via the AWS EC2 Console and AWS CLI without any issues. I used the latest EC2 console hence, I do not think there is any known bug.

Retry on an Incognito browser mode or clear the Browser cache and try again.

Note that I also tried with your IAM permission and it worked fine

If issue persists, feel free to contact AWS Premium Support

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions