Issue with Custom Domain Mapping and SSL Certificate for Elastic Beanstalk WordPress Environment

0

I am experiencing difficulties with mapping my custom domain and SSL certificate to my Elastic Beanstalk environment running a WordPress application. I have carefully followed the necessary steps and configurations, but the custom domain (pinoyagri.com) is not being applied to the Elastic Beanstalk environment as expected. Here are the key points of my setup:

I have created a Route 53 hosted zone for my custom domain (pinoyagri.com). I verified that the nameservers listed in my domain registrar match those in my Route 53 hosted zone. I attached the SSL/TLS certificate to the Application Load Balancer (ALB) associated with my Elastic Beanstalk environment. In Route 53, I created an "A" record with alias targeting the correct ALB (Application Load Balancer), region, and environment. I ensured that both HTTP (port 80) and HTTPS (port 443) traffic are properly configured in the ALB. The ALB is correctly forwarding traffic to the target group associated with my Elastic Beanstalk environment. I have confirmed that HTTP traffic is being redirected to HTTPS. Despite these steps, when I access my domain (pinoyagri.com), the default Elastic Beanstalk domain (http://pinoyagrisite-env.eba-h9wukwhm.ap-southeast-1.elasticbeanstalk.com/) is displayed instead of my custom domain. Any idea guys how to fix this? Thank you in advance for any help.

profile picture
Vin
asked 7 months ago200 views
1 Answer
1
Accepted Answer

Hello.
When I access your domain (https://pinoyagri.com/) with my browser it appears to be displaying correctly.
Are there any caches, etc. left on your local machine?
web

profile picture
EXPERT
answered 7 months ago
  • If you click on "Pinoy Farmers Hub" or something similar, you will see the domain name of Elastic Beanstalk, so please make sure that your WordPress site URL is set correctly.

  • Ah okay I got it. Thank you so much Riku! I'm creating this website so that my fellow Filipino farmers will be able to promote their products for free.

  • There's another issue. When I try to login this URL showed up: https://pinoyagrisite-env.eba-h9wukwhm.ap-southeast-1.elasticbeanstalk.com/wp-login.php and it is not the pinoyagri.com. How to set this correctly?

  • Changing the site URL settings in wp-config.php, etc. or modifying the site URL directly in the database may fix the problem. You should be able to see the URL currently set by accessing the database and executing the following command.

    select * from wp_options where option_name = 'siteurl';
    select * from wp_options where option_name = 'home';
    

    If the DNS name is the Elastic Beanstalk DNS name, try the following command to correct it.

    update wp_options set option_value = 'https://pinoyagri.com'  where option_name = 'siteurl';
    update wp_options set option_value = 'https://pinoyagri.com'  where option_name = 'home';
    
  • Thank you for getting back. I need to start all over again because I forgot to download the key pair file.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions