EMR : cron: A yarn command is skipped

0

On EMR trying to add yarn command to cron.

I tested directly calling yarn command in cron. But it seems to be skipping that command.

This is the command added to cron

*/1 * * * * hadoop date;yarn

No matter where I put even script skips it. If I execute a script manually it works. Just via cron yarn is not even attempted

asked 2 months ago16 views
2 Answers
0
Accepted Answer

Thanks for you response. Yes the intention is to run multiple commands. It does not need to be in inside ( ). I have verified this. It inly needs to be separated out with semi-colon. And I was able to find the problem. The command was failing with some environment variable settings and it is good now. It wasn't a issue with yarn command or cron. Thanks again for responding.

answered 2 months ago
0

The command mentioned above hadoop date;yarn looks incomplete. Can you please share an example of what you are trying to do?

If the intention is to run multiple commands in a cron you can surround the semicolon separate commands inside a ( ), for example */1 * * * * (hadoop version;yarn version). I hope this answers your question, if not please share more details on the use case and I'll be happy to assist you.

SUPPORT ENGINEER
answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions