Set wal_level to minimal for RDD Postgres 13


Running Postgres 13 in RDS, is there any way to get the wal_level set to minimal? I see that turning on rds.logical_replication will set wal_level to replica, but I have rds.logical_replication off and the wal_le!vel is still replica instead of minimal.

Screenshot showing wal_level and rds.logical_replication

1 Answer

Dear AWS Customer,

Unfortunately, WAL_LEVEL parameter cannot be modified directly because as RDS is a managed service and there are certain restrictions on what parameters can be modified. Also, As per the screenshot ,the instance seems like a RDS Postgres read replica (current/past) which itself does not support logical replication hence the wal_level can’t be modified.

It is dependent on the RDS Postgres parameter "rds.logical_replication" which went set to 1 via custom paramter group and given a reboot , sets this parameter "WAL_LEVEL" to "logical".

Note: "rds.logical_replication" parameter is used to enable logical replication on an RDS PostgreSQL DB instance.

More information about it:

Currently community version for Postgres doesn't support setting up logical replication in a replicated Postgres instance and hence RDS Postgres also doesn't support the same.

Once the specific feature is available in the community version of Postgres we can expect it to launch in RDS Postgres. Currently, we don't have an ETA on it.

I hope above information helps. However, if you have any questions or concerns related to this issue please reach out to AWS Support.




answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions