Lightsail: "your server does not support using .htaccess files from custom locations" how to fix?

0

I am using Lightsail for my wordpress and was trying to configure the "Converter for Media plugin with WebP and AVIF support". However, I am getting the following error after activating the plugin and I have no idea what this means... Can anyone shed a light on where to go from here?

It appears that your server does not support using .htaccess files from custom locations, or it requires additional configuration for the plugin to function properly.

If you are using Nginx server, please contact your hosting support (or server administrator) and provide them with the following message:

I am trying to configure Converter for Media plugin with WebP and AVIF support. In order to do this, I need your help adding the required rules to the Nginx configuration of my website - https://www.aquavue.co. More information can be found in the plugin FAQ: https://wordpress.org/plugins/webp-converter-for-media/faq/ (in the question: Configuration for Nginx)

If you are using Apache server, this issue is usually related to the virtual host settings in the Apache configuration. In the .conf file appropriate for your VirtualHost, in the <Directory>...</Directory> section, replace the value of AllowOverride None with the value of AllowOverride All. In this case, please contact your server administrator.

---

Error codes: rewrites_not_executed
asked a year ago700 views
1 Answer
0

This error message indicates that the server that you're using (Lightsail) doesn't support the .htaccess files that are required for the "Converter for Media" plugin to function properly.

The plugin requires either Nginx or Apache server to be configured properly in order to function. If you're using Nginx, contact your hosting support or server administrator and provide them with the information listed in the error message. If you're using Apache, the issue can be resolved by modifying the virtual host settings in the Apache configuration file, as described in the error message.

Specifically, you need to change the value of "AllowOverride None" to "AllowOverride All" in the <Directory>...</Directory> section in the .conf file for your VirtualHost. Contact your server administrator for assistance with this.

profile picture
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions