problem in Amazon SageMaker

0

ValidationException 1 validation error detected Value '[]' at 'subnetIds' failed to satisfy constraint: Member must have length greater than or equal to 1

  • What is the command you're trying to execute? Looks like you're missing subnets in your command.

asked a year ago486 views
1 Answer
0

As Durga_S mentioned, it looks like you could be missing a subnet if you are calling a SageMaker API. From the description however it's difficult to know where or what conditions led to the error. Another user encountered the same error from the console when launching a SageMaker Studio Domain as seen this StackOverflow where the solution was to use "Standard Setup" instead of "Quick Setup".

To resolve: (1) If you are using CLI or SDK then feel free to add a subnet and information on how to do this can be found in the documentation (i.e. SageMaker Boto3 docs). (2) Refer to the link if you are seeing this when creating a SageMaker Studio Domain. (3) If you are using the console, and the above solution does not resolve your error, then please share additional details. It may be beneficial to use the browser developer tools to see what API is called when clicking certain buttons.

AWS
SUPPORT ENGINEER
answered a year ago
  • My purpose is to use an RStudio available in SageMaker. In the Amazon SageMaker I clicked the RStutio, which directs me to "Create a SageMaker domain". After clicking this, I have 2 options for set up: Quick or Standard. The problem persists in both options.

  • You'll need to specify a subnet for either setup, so that Studio can set up EFS in that subnet for storage. To resolve this, provide a VPC, subnet and security group for your domain.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions