Aurora Serverless V2 doesn't drop the database on DROP.


Hello there,

I'm trying to drop a DB on the Aurora, but the requests just hangs. I've tried several times and the last attempt has been runnning for 600 seconds. it's a tiny DB of 20MB gzipped.

  • running show databases; returns the borken_db in the list.
  • running use broken_db;now hangs too.
  • running show processlistreturns the following:
    5event_schedulerlocalhostDaemon8310Waiting on empty queue
    38root_user10.0.0.48:36788mysqlQuery2736Waiting for schema metadata lockDROP DATABASE broken_db
    47root_user10.0.0.48:36826mysqlQuery2346Waiting for schema metadata lockdrop DATABASE broken_db
    50root_user10.0.0.48:36854Query1990Waiting for schema metadata lockUSE broken_db
    51root_user10.0.0.48:36874mysqlQuery0initshow processlist
    52root_user10.0.0.48:36894mysqlQuery1042Waiting for schema metadata lockuse broken_db
    58root_user10.0.0.48:36922Query178Waiting for schema metadata lockuse broken_db

where do I go from there?

1 Answer
Accepted Answer

I've solved the issue by killing all the processes with kill {ID} related to broken_db. I've then rebooted Aurora, and now the drop worked.

I don't have answer how/why it happened originally.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions