By using AWS re:Post, you agree to the Terms of Use
/how to resolve "site not reached, <ip address of ec2 instance> refused to connect" error when trying to create s3 file gateway?/

how to resolve "site not reached, <ip address of ec2 instance> refused to connect" error when trying to create s3 file gateway?

0

I'm trying to create file gateway so I can set up file share. For host platform I'm using EC2 instance but when I give the ip address of my EC2 instance I get error "This site can't be reached" "<ec2 ip address> refused to connect". I've followed this guide to make sure that I've configured everything correctly and it doesn't look like I've missed anything. Any help with what I'm doing wrong? https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/TroubleshootingInstancesConnecting.html#TroubleshootingInstancesConnectionTimeout

1 Answers
0

Hi, please check if you are able to connect to the gateway IP address on port 80 from your workstation where you are trying to activate the gateway. For gateway EC2 instance, please check whether its security group rule allows ingress port 80 from your workstation client IP address. Port 80 is needed only for activation, you can remove the rule after the activation is completed.

https://docs.aws.amazon.com/filegateway/latest/files3/Requirements.html#requirements-network

Alternative method to activate is, to fetch the activation key from the gateway VM/EC2 local console, using option 0: Get Activation Key and provide that during the activation wizard. Below are the instructions for DataSync console to get the activation key, but these should be almost similar to gateway VM as well.

https://docs.aws.amazon.com/datasync/latest/userguide/local-console-vm.html#get-activation-key https://docs.aws.amazon.com/filegateway/latest/files3/create-gateway-file.html#connect-to-amazon-s3-file

answered 2 months ago
  • Hello, I've checked that port 80 is present in the inbound ports for ec2 security group however when i test connection in powershell using following command: tnc <ec2 public ip address> -port 80, the connection fails. What can I do to solve it?

  • I am assuming that you may not be using the correct or latest AMI that is required to host the storage gateway instance. I would suggest checking that you are using the latest storage gateway AMI in your region and meets the hardware configuration. If you are still encountering issues after using the recent gateway AMI, please private message me the EC2 instance ID.

    https://docs.aws.amazon.com/storagegateway/latest/userguide/ec2-gateway-file.html

  • This still isn't working for me. What is the latest AMI we should be using?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions