Athena Error No: 100, HTTP Response Code: 502, Error Message: Failed to parse error payload

3

I have an app that has been connecting to Athena via OBDC with no previous issues. All of a sudden I am getting the following error as of Monday Oct 3rd:

Warning: Error in : nanodbc/nanodbc.cpp:1655: 00000: [Simba][Athena] (1040) An error has been thrown from the AWS Athena client. Athena Error No: 100, HTTP Response Code: 502, Error Message: Failed to parse error payload [Execution ID: c6c6a1bc-d7ea-4f79-bccd-e90aa6e767f7]

When I look up the execution ID in athena, there is no error. The query runs successfully on athena and it looks like the issue is between the Athena Client and Athena. Unfortunately the error message is really ambiguous but the Error No: 100 suggests that it is an internal service error. Any advice on how to debug this further would be much appreciated.

Thanks!

  • in every forum that i looking for this issue the solution is the same. Like SSTENS However, this slows the query speed down a lot so a permanent solution needs to be found. Something definitely changed in the last 24 hours as I had never seen this error before yesterday. Like Alejandro_aviles muy issue started since Oct3rd. Any solution that solve this issue without lost query speed??

benk
asked 2 months ago469 views
3 Answers
4

There is an internal issue going on in the backend which is giving rise to the error for many of the users. Confirmed this with the internal team as well. They are actively working towards it's resolution. Currently, as a immediate workaround please try setting the UseResultsetStreaming=0 as suggested by @sstens. Any inconvenience caused due to this is deeply regretted.

profile picture
SUPPORT ENGINEER
Chaitu
answered 2 months ago
EXPERT
reviewed 2 months ago
  • The internal issue has been resolved October 4 6:18 PM PDT

  • @Fabrizio@aws which solution that solve the issue and not create slows the query speed dow. could you explain please?

2

Exact same issue as you, please post if you find a solution. As a temp fix, you can add UseResultsetStreaming=0 to the connection string (or configure it in Advanced Settings in the DSN). However, this slows the query speed down a lot so a permanent solution needs to be found. Something definitely changed in the last 24 hours as I had never seen this error before yesterday.

sstens
answered 2 months ago
  • Thanks sstens! Setting UseResultsetStreaming=0 is working as a workaround for now, but it is indeed slower.

0

Same error here, searching for an answer everywhere, but clueless about solution. ResultsetStreaming=0 worked for me, but waiting to understand what happened. It started since Oct3rd, so I think it can be general.

If you find any solution, please post here!

answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions