Ghost lightsail istance - Mixed content HTTPS HTTP

0

Hi there,

After successfully setting up my Ghost Lightsail instance and following the Ghost getting started guide, I've encountered an issue. Despite setting up everything, including the SSL certificate, the website is fully running via HTTPS, but I'm experiencing issues with fetching content such as header images and logos, which are all fetched using HTTP.

Upon reading the Ghost documentation, I ran ghost config get url and found that my domain was http://mydomain.com. I then attempted to update the Ghost configuration by running ghost config url https://mydomain.com && ghost restart, it indeed updated the domain with https:// but unfortunately, Ghost was unable to restart and provided an error.

Referring to the Lightsail Ghost documentation, I used sudo /opt/bitnami/ctlscript.sh restart to successfully reboot my Ghost.

However, now the website no longer works. Whenever I try to access https://mydomain.com, it redirects me to https://127.0.0.1:2368/.

It's frustrating that this issue occurred, especially considering that the blueprint Lightsail instances should be bulletproof and ready to use. Could anyone provide assistance on what steps I should take next to resolve this problem? Thank you.

Fra
asked 17 days ago63 views
1 Answer
0

Hello,

Greetings for the day!

I tried replicating the issue in my test environment and I was able to run the ghost config url command and for my Lightsail, the redirection issue did not occur. However I tired researching on your issue and I found below articles which might be useful : https://stackoverflow.com/questions/73268081/vm81-mixed-content-issue-with-ghost

https://forum.ghost.org/t/switching-to-https-redirects-blog-to-localhost-and-makes-the-blog-not-load/14969

Note : It is recommended to take a backup of your LightSail instance before performing any changes in it. https://lightsail.aws.amazon.com/ls/docs/en_us/articles/lightsail-how-to-create-a-snapshot-of-your-instance Thank you

AWS
Gopal_M
answered 16 days ago
AWS
SUPPORT ENGINEER
reviewed 12 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions