By using AWS re:Post, you agree to the Terms of Use

Help needed to create CI/CD pipeline with Jenkins


I'm trying to create CI/CD with Jenkins by following this AWS workshop and I am stuck at point 1. When I go to the Jenkins server URL it is not reachable from internet. I've verified my IP range from which I can connect to and it's correct. I've verified that the subnet the server was provisioned to has the IP CIDR range and it is associated with a route table that has an entry to route all traffic to Internet Gateway. I can SSH to it but can't access it from the browser. What am I missing?

3 Answers

Step 1 looks to be concerned with Cfn that provisions the resources. Have you completed step 2? It looks like Step 2 discusses how to access, unlock, and customize the Jenkins server.

answered 9 months ago
  • No, I haven't completed step 2. When I try to look what's inside the /var/log/jenkins/jenkins.log file it says that the file doesn't exist.

    sudo su
    cat: /var/log/jenkins/jenkins.log: No such file or directory

Hi! Good question.

A couple things to verify from step 1:

  • Where are you connecting to the Jenkins server from when you try to SSH?
  • When you say route all traffic to the Internet Gateway, are you referring to ingress (inbound) or egress (outbound)?
  • Does the Jenkins server have the proper Security Group allowing ingress for both Web Traffic (from where you are going to access the Jenkins server) and SSH traffic?
  • Is the Jenkins server properly setup in a public subnet as per the values provided here: is part of a Private Address space (RFC 1918).

In Step 2, to configure the Jenkins server, you will need to do the following:

  • Try looking in /var/jenkins_home/secrets/initialAdminPassword as well for the password.
answered 8 months ago
  • How do I configure the subnets properly? How would I modify this template to create a completely new VPC and proper subnets? I'll try it again from scratch because I think that the subnets are not properly setup.


Do you have port 80 for http or port 443 for https open for the user you are using to access the server in your browser?

answered 8 months ago
  • I accidently noticed yesterday while doing something else that Chrome by default tried to open the URL by HTTPS and HTTPS was not enabled in the Security Group so that's probably why it didn't work. I'll give it a try one more time. Appreciate your help.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions