aws smb for windows not connecting to active directory made by AWS director

0

I am trying to set up a network drive on my windows 10 home desktop that can reach my files in S3 using the storage gateway. I have done the following:

1.) Set up a m4.xlarge EC2 server with 150GB of EBS to serve as cache
2.) I have configured the required ports of 80, 22, 139, and 445 for SMB
3.) I have used AWS active directory service to set up my microsoft AD in the AWS cloud
4.) I have created the file gateway
5.) When I click edit SMB settings and type in my active directory, username, and password, the active directory status says failed to join ( network error).

Can someone please help me? I have had no luck and have been going around in circles.

asked 3 years ago135 views
2 Answers
0

This issue is normally caused when the gateway is unable to resolve the domain used to the domain controller addresses.

Since this is AWS Managed AD, It's recommended to use the domain controller IP addresses as the DNS servers for the Storage Gateway.

Once that is set then the join domain should succeed.

Thank you,
Brian C @AWS

Brian C
answered 3 years ago
0

got it

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions