Skip to content

Getting error: Error when retrieving credentials from container-role: Error retrieving metadata: Received non 200 response 500 from container metadata: <?xml version="1.0" encoding="iso-8859-1"?>

0

Whenever I run the "aws sts get-caller-identity" command, I get the error:

"Error when retrieving credentials from container-role: Error retrieving metadata: Received non 200 response 500 from container metadata: <?xml version="1.0" encoding="iso-8859-1"?>".

My user has AWS admin access as well as Cloudsell full access.

Any help on why this is happening and how to resolve it will be greatly appreciated.

asked 2 years ago4.5K views

1 Answer
0

Hello.

I've seen such errors occur when the session is expired.
So, please try signing in to AWS again or restarting CloudShell.
Also, try accessing from another browser or PC.
https://docs.aws.amazon.com/cloudshell/latest/userguide/getting-started.html#restart-shell-session

EXPERT

answered 2 years ago

EXPERT

reviewed 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.