By using AWS re:Post, you agree to the Terms of Use
/Why is there a recommended version for MSK/

Why is there a recommended version for MSK

1

If you look at the supported version of MSK (https://docs.aws.amazon.com/msk/latest/developerguide/supported-kafka-versions.html) you'll notice that there is a supported version (currently 2.6.2).

Anyone an idea why? What's the drawback with other/newer versions? Less tested? Less stable? ...?

1 Answers
0
Accepted Answer

We recommend versions that have been extensively tested by our service are believed to be stable. Older versions are no longer recommended as they might miss some new Kafka features, and newer versions are not recommended because we haven't tested them enough yet to feel comfortable recommending them broadly. Having said that, you are welcome to use all supported versions with high confidence.

answered 4 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions