Can't connect MySQL Workbench to my Aurora RDS database.

0

I am trying to connect MySQL Workbench to my AWS Aurora RDS database. In RDS I have allowed public access as well as created an inbound rule that allows my local computer's IP address to access it. In MySQL Workbench I have correctly inputted the endpoint as the host name and properly inputted my master username and password and set the port to 3306. It doesn't connect. I use MySQL to connect to other non-AWS remote servers, so I don't believe this is a firewall issue.

  • Hi Matt.

    Can you share what is the error showing after trying to connect? Also, have you checked your CloudWatch logs for additional information?

    Thank you

Matt
asked 6 months ago341 views
3 Answers
0

Hello Matt,

What happens when you try to connect ? Connection times out ? If that's the case then you can't reach the RDS Instance from your network.

Would you mind to answer some questions ?

  • In which type of subnet your instance is ? Public or Private ?
  • Are you connected to any kind of VPN ?

Security Groups and the RDS Allow Public Access option are not the only things that can prevent you from reaching the instance.

You must make sure that your instance is reachable from the outside and that it can reach the outside too:

  • Check for Network ACLs. NACLs are stateless, which means that you must allow inbound AND outbound traffic (by default they allow everything).
  • Check if you have Internet and Nat Gateways properly configured. You can't leave your VPC without them (or at least the IgW).
  • Check your VPC's Route Tables. Your instance packets must be forwarded to a gateway (either ig or ng depending on the subnet).

ps: You wouldn't need any of these if you have a direct connection or vpn access to the vpc and if that's the case then you can access the instance privately.

If this doesn't help you, please answer the questions so I can help you better.

answered 6 months ago
0

Here's the error message I get from Workbench when I try to connect to the database: AWS / MySQL Workbench failure

Matt
answered 6 months ago
0

When you say you have added your local computer IP address. Do you mean it’s local IP? If so, you actually need to allow your public broadband IP address of your router. You can find your IP address you need to add here. https://whatismyipaddress.com/

Add that Ip address to your security group rules.

profile picture
EXPERT
answered 6 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions