Migrating Azure SQL Database, getting error: Failed to get indication whether cdc is enabled.


I am having trouble getting one specific Azure SQL Database source endpoint working. When I use the Test Connection feature of the Endpoint, I get the following error:

Application-Status: 1020912, Application-Message: Failed to get indication whether cdc is enabled. No data returned., Application-Detailed-Message: RetCode: SQL_ERROR SqlState: 42000 NativeError: 40515 Message: [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Reference to database and/or server name in 'rdsadmin.dbo.rds_show_configuration' is not supported in this version of SQL Server. Line: 1 Column: -1

I have successfully migrated about a dozen other Azure SQL Databases, it's just this one in particular that gives the error. Other databases on the same Azure SQL Database server instance work, other database on other servers work, other databases that also have an active Azure SQL replication to another Azure region work. Even a copy (done via the Azure portal) of this database to the same server works. The SQL compatibility version of this database is 140 - again, like all the other ones that work.

Migrating the copy of this database I made might be a workaround, but creating the copy in Azure takes about 50 minutes and we can't afford that downtime.

I feel like this a very specific bug or incompatibility, is there anyone on the DMS team who can help out?

asked 8 days ago38 views
1 Answer

Hi Paul, could you possibly try disabling and re-enabling CDC on that DB (https://learn.microsoft.com/en-us/sql/relational-databases/track-changes/enable-and-disable-change-data-capture-sql-server?view=sql-server-ver16), and try it from another admin user account, i.e, not your current one.

Let us know if this works!

profile pictureAWS
Thiru A
answered 8 days ago
  • Hi, I don't have CDC enabled on any of the databases, because DMS doesn't currently support using it on Azure SQL. But I tried turning it on, then disabling it. I also tried enabling it again. Neither helped. I tried creating another SQL user with db_owner role and used that in the connection, still the same error unfortunately.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions