AWS Backup with VMWare Standalone ESXi Host - Failed to upload backup during data ingestion


I have a standalone ESXi host (v7.0.3) that I'm trying to configure a couple of VMs to backup with AWS Backup. I've been able to setup a gateway, add the hypervisor and VMs and all reports as online/working but any time I try to create an on demand backup for any VM I get the error -

Failed to upload backup during data ingestion. Aborted backup job I've checked the vmware log for the VM and can see it successfully consolidate the disk and create snapshots (and later delete the snapshot during cleanup) but nothing to explain the error. To rule out any permissions issue with the hypervisor, I tried adding the account AWS is using for backup to the admin role on the hypervisor - no difference. Where can I find more information about the error and what might cause it? Any info/help appreciated.

asked 2 years ago1573 views
1 Answer

I would recommend to check from the local gateway appliance if all API endpoints are properly reachable. To do this you need to connect to the local console of the gateway, e.g. via the ESXi management console or via vCenter. After you login (the default credentials are admin/password, please change the password if this is still the case) you can select option 3 from the menu: Test Network access.

Depending on your chosen setup it lists either the public or VPC endpoints the gateway needs to connect to.

answered 2 years ago
  • So I did check and can confirm the endpoints are reachable... I've found when I trigger the backup that network usage for the Gateway spikes for about 10 minutes or so before the failure so it looks like the transfer starts but just doesn't complete. Are there any other logs for the gateway itself that might provide better detail??

  • I am having this same issue with a standalone ESXi server (v6.7.0). My firewall clearly shows a lot of data outbound to AWS for around 3 hours once, then about an hour, and then the backup fails with this message. I have tried an on-demand backup and a plan-scheduled backup with the same effect. Running option 3 from the gateway console shows all three endpoint connection tests passed. There don't appear to be any additional logs or data of any type available for troubleshooting.

  • Hi @Sabs, Hi @mlerley,

    I'm sorry for the late response, I was off for a few days. I would recommend to open a support ticket via the AWS Support console.

    @mlerley: If the connection gets cut after 3 hrs I would recommend to check your firewall settings for parameters like maximum "TCP session lifetime" or similar. Maybe the connection is stable but get's cut after that time.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions