PSI Secure browser didn't launch while exam


I had scheduled AWS Cloud practitioner exam on 31st dec 6 PM IST. Verified the system check as mentioned before and logged in on correct timing. But when I launch the exam, it asked yo install PSI Secure browser to start the exam, but unfortunately it didn't work. Contacted support team to resolve, although tried in 2 different laptops with different network, nothing worked. Took almost 2 hours but no luck.

Contacted PSI team multiple times after that, but no support from anyone. It's irritating without any reply or any help about next step.

Please guide on next step whether it will be rescheduled or refunded? I have used 50% voucher as well. So what will be the status of my exam.

1 Answer

Please submit a ticket to the AWS Training & Certification customer support team, and they will provide assistance. If you already submitted a case, please allow at least 48 hrs to get a response.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions