By using AWS re:Post, you agree to the Terms of Use

AWS WorkSpace Problems When using Mac Keyboard

0

AWS WorkSpace Problems When using Mac Keyboard, so their are times when I run into UAC prompts on Windows 10, it prompts me to press Control + Alt + End.

When I am using a Windows client and an external keyboard I simply press Control + Alt on the client PC then on AWS workspace I press delete then this works.

Sometimes within AWS workspace I can use the menu option to send Control + Alt + Delete

However if I RDP to a Windows 10 client inside my Windows 10 Workspace that won't work.

The Macbook. keyboard doesn't support Control + Alt + Delete command natively. ( Of course as it doesn't have the keys).

I try to press Option and Command on my Mac keyboard then open up virtual keyboard on the AWS Workspace and press delete. I know this should work as Control + Alt (turn blue) and the Del key turns white when I press it.

So yes it should work but no it doesn't. I am at a loss any ideas? I have already tried to follow this guide and run this command. https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-osx-client.html defaults delete com.amazon.workspaces SUSkippedVersion

Still doesn't work what am I doing wrong?

asked 2 months ago64 views
3 Answers
0

Bumb any update on this?????

answered a month ago
0

No this still wont work....

answered a month ago
-1

Hi There,

I understand that you have an issue with AWS WorkSpace When using Mac Keyboard where The Macbook keyboard doesn't support Control + Alt + Delete command natively and have followed the documentation [1] accordingly to setup.

I have found that on an extended keyboard Ctrl ⌃ + Alt ⌥ + Delete ⌦ is the correct method.
On a short keyboard you need to press Ctrl ⌃ + Alt ⌥ + Fn + Backspace ⌫

Please Note:
[Option] is [Alt] in all cases.

Some Mac keyboards actually say Alt, some say Opt & some only have the symbol ⌥. 
The key is the same.


The Fn + Backspace ⌫ method will also work on an extended keyboard if you feel the need.

Please also note:
The Secure Keyboard Entry option on macOS can prevent the Amazon WorkSpaces client from receiving input from the operating system if enabled.

To disable Secure Keyboard Entry on macOS, follow these steps:

  1. Open a Terminal window.

  2. On the menu bar, choose Terminal, then clear Secure Keyboard Entry.

Further more please see the documentation [2] .

I hope this information is helpful.

============Reference============

[1] https://aws.amazon.com/premiumsupport/knowledge-center/workspaces-keyboard-issues/

[2] https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-osx-client.html

answered 2 months ago
  • I have tried all of these and no it doesn't work the issue I have is that after conecting to a RDP session and try to run regedit for example we hit a UAC box. It asks me to press CTL+Alt+End

    On a Windows machine If I press CTL+Alt on the laptops physical keybaord them press delete on the Virtual keyboard in the RDP this works.

    On a Macbook I can see that the CTL+Alt is working as they keys on the virutal keyboard turn blue but as soon as I try to press Delete nothing happens and the key stays grey.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions