By using AWS re:Post, you agree to the Terms of Use
/AWS LoRaWAN - DownLink Issues/

AWS LoRaWAN - DownLink Issues

0

Hello

I am working with IOT Wireless with LoRaWAN

I have 868 MHz - Class C devices with confirmed messages. Messages are not always being actioned by my devices. I can see the message in the Downlink message queue.

Its my understanding that if the message is confirmed it should either arrive at the device or there should be some indication it failed.

I some times see the following CloudWatch Log:

{ "timestamp": "2022-03-21T07:44:03.2699141Z", "resource": "WirelessDevice", "wirelessDeviceId": "xxxxxxxxxxxxxxxxx", "wirelessDeviceType": "LoRaWAN", "devEui": "xxxxxxxxxxxxxxx", "event": "Downlink_Data", "logLevel": "ERROR", "messageId": "9114ba31-84af-44eb-ab1b-a92b67addbbb", "message": "Downlink message failed. MessageId: 9114ba31-84af-44eb-ab1b-a92b67addbbb" }

But why did it fail ?

How can I find out more on what the cause is?

In additon to this I have tried Multi-Cast but that also doesn't work with all devices stuck as: Package attempting

Note I have tried the devices / gatways with TTN and I have no issues.

Thank you

JT

asked 3 months ago30 views
1 Answers
0

Hi JT. Please take a look at our AWS IoT Core for LoRaWAN workshop, particularly the new downlink and multicast downlink sections as they may help you: https://catalog.us-east-1.prod.workshops.aws/workshops/b95a6659-bd4f-4567-8307-bddb43a608c4/en-US/470-downlink

For debugging the unicast downlink, in addition to the CloudWatch logs, have you used the Network Analyzer? https://docs.aws.amazon.com/iot/latest/developerguide/connect-iot-lorawan-network-analyzer-overview.html

Furthermore, if you have access to the Basics Station logs on your gateway, you can see the uplink and downlink messages there: https://doc.sm.tc/station/tcproto.html#

Finally, in regards to multicast downlink, AWS IoT Core for LoRaWAN implements the LoRaWAN Remote Multicast Setup Specification: https://lora-alliance.org/resource_hub/lorawan-remote-multicast-setup-specification-v1-0-0/ . Your device must implement this too for it to be able to participate in multicast sessions with AWS IoT Core for LoRaWAN. From https://docs.aws.amazon.com/iot/latest/developerguide/connect-iot-lorawan-multicast-status.html :

Package attempting

After your devices have been associated with the multicast group, the device status is Package attempting. This status indicates that AWS IoT Core for LoRaWAN has not yet confirmed whether the device supports multicast setup and operation.

answered 3 months ago
  • Thanks

    I have reached out to our vendor to see if that multicast method is supported. I suspect its not. That will answer why it doesn't work.

    I have enabled extra loging now via the CLI for cloud watch - Thank you for the link.

    Is there anyway to retry a failed delivery ? Some times some network issue might mean the command needs to be sent again.

    JT

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions