By using AWS re:Post, you agree to the Terms of Use

Error when trying to add db instance to VS server explorer

0

I am trying to add an SQL database to a SQL DB instance that I set up through the AWS toolkit from inside of Visual Studio. Setting up the DB instance worked fine and I only had to wait around 5 minutes for my micro instance to spin up and list its status as "available."

However, when I try to create an SQL database inside that instance using the right click -> "Create SQL Server Database" or "Add to Server Explorer" menu options, I get an error when I attempt to add my IP to the security group so I can access it. The error text is "Error adding permission: Nullable object must have a value."

Here is a screenshot of the error as well: http://i.imgur.com/fydZmGI.png

What could be causing this?

asked 3 years ago32 views
1 Answer
0

I have solved the issue; unfortunately I used the default set public to no. Once I set this to yes everything went through fine!

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions