Grafana + SAML failure: Failed to save the SAML received information


I tried setting up Managed Grafana, and used our corporate Active Directory as the IdP. As far as anyone can tell, the request to AD is authorized; the AD logs show that it succeds. I click on "Sign in with SAML", go through the AD login with 2FA, but the grafana login fails with the message "Failed to save the SAML received information" SAML failure.

Looking at the Network tab of the developer tools, the failure is in "writer", whatever that is: Request URL: Request Method: GET Status Code: 401 Unauthorized Remote Address: Referrer Policy: strict-origin-when-cross-origin

As far as I can tell, I have followed to the letter. is not of any help either.

I have many skills, but Microsoft AD magic spells is not one of them. Help?



2 Answers

Am I correct that you are using Azure Active Directory?
Have you reviewed the following documents?

Basically, if you have followed the steps in the following document, there should be no problem on the AWS side.

profile picture
answered a year ago
  • I am following the instructions to the letter. I looked at the browser (Chrome) developer tools, and what is failing is a call to with the following information:

    Request Method:
    Status Code:
    401 Unauthorized
    Remote Address:

    The role under which grafana is running has grafana:* in the actions, and "*" in the resources! How much more permissive can it get?


Hello @ji I'm having the same issue did you solved your issue?

answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions