By using AWS re:Post, you agree to the Terms of Use

OpenSearch Cluster max clause count not updating

0

Currently, I have an OpenSearch cluster that has a **Max Clause Count **of 1024. I want this value updated to 4096. I have updated the value within the cluster configuration settings and the dashboard has confirmed that the update was completed. However, when testing, I get the following error:

{"type":"too_many_clauses","reason":"maxClauseCount is set to 1024"}

Indicating that the update was somehow not successful.

Any suggestions as to what I need to do to remedy this? Thanks!

asked 6 months ago18 views