By using AWS re:Post, you agree to the Terms of Use
/IP doesn't redirect to the domain/

IP doesn't redirect to the domain

0

I keep getting SafeMode activated message on my Wordpress website, even after I have tried to transfer connection or create a new connection.
My brother has helped my set up the hosting and we did it following the instructions on AWS Lightsail. So we set it up with the IP address 18.168.98.182 and I first logged in to my dashboard via this link http://18.168.98.182/wp-admin/ . I have installed jetpack and woocommerce payments plugins. Then I’ve got my own domain name beadembroideryart.com and I think this created a duplicate page or something like that. Now I login to my dashboard via http://beadembroideryart.com/wp-admin/ . But the problem is that every now and again I get a notification SafeMode activated transfer your connection from 18.168.98.182 to beadembroideryart.com or create new one. When I click transer connection it goes away for a short time and comes back again in a while. When I do a new connection it’s the same and the only difference is that I need to set up my payments again from the start. I don’t know what am I doing wrong as there is no other option to choose from. Does this mean that the IP doesn’t redirect to the domain and this causes a duplicate connection conflict for WooCommerce Payment detection?

2 Answers
0

Thank you for your response but the problem is that now I can access my dashboard both ways via IP address and via my domain name and see exactly the same site but in general settings on each of them says correspondingly either an IP address or my domain. Ideally I would like to somehow remove the connection to Wordpress via an IP address, but I don’t know if that is possible at all? Just don’t want to lose anything as I have done a lot of work on the website in the last week

answered 3 months ago
  • This is by design in case your domain is not accessible. However, you can set up the htaccess to forward the IP to the domain. If you are using the bitnami image, you can adjust the htaccess.conf and do something like:

    RewriteEngine On RewriteCond %{HTTP_HOST} ^ 18.168.98.182$ OR RewriteRule (.*)$ http://beadembroideryart.com/$1 R=301,L

    I also recommend setting up HTTPS/SSL if possible for better security.

0

Well, running a dig command on beadembroideryart.com points to 18.168.98.182 so it seems like you DNS is setup correctly which means it's most likely a Wordpress configuration issue. Have you checked your general site settings to see what it shows for site name? It's possible that since you set this up prior to getting the domain name, that it has the IP address listed as the site name instead of your domain name.

answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions