By using AWS re:Post, you agree to the Terms of Use

lost partition after volume stuck to detach

0

I have an EC2 instance with 3 volumes (1 root sda1 and other two sdf and sdg, ).
I wanted to delete volume sdf so I umount it and tried to detach it but suddenly it went busy state and the instance stopped to respond. I wait some minutes but no change.
So I tried to force detach but again no success.
Then I shutdown the instance and the detach completed.
After I power on again the instance I found that the second volume sdg was umounted and there was no more partition table on it !!!
I dont know what happened and how detach one volume afffect other volume.
Now i need to recover my data and I dont have business plan to get AWS support.
I already did a snapshot and now Im trying to figure out what to do.
Can someone here give me any help ?

asked 2 years ago15 views
1 Answer
0

i solved my problem with testdisk.
Still i feel is not correct aws do not support their services if you not pay extra for support plan.

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions