DeepLens - How to fix "The security token included in the request is invalid"?

0

I'm going through the process of registering my DeepLens.

The moment I go to the page for registering my lens with V1, I get a message of "The security token included in the request is invalid".

If I instead go through the V1.1 process, I get the same message after hooking up my DeepLens, and setting up the internet.

Under either path, the lens fails to register.

Any ideas?

Trouble Shooting So Far:

  • Tried issuing new security key
  • Tried using root account and IAM role
  • Tried clearing cache
  • Tried using a different account
  • Tried using a different computer
asked 2 years ago1717 views
2 Answers
0

The path that worked for me so far (there is no way this is intended):

  1. Start to register the camera using V1.0. Make it far enough to get wifi enabled, but not far enough that they let you download a cert...
  2. Cancel out of that, and go to register with V1.1, make it almost all the way through till it blocks you at "The security token included in the request is invalid"
  3. Go into IAM and delete all of the service roles related to DeepLens/GreenGrass
  4. Watch as randomly it lets you through when you keep trying to register (what the heck)
  5. Cry as it infinitely spins on trying to get certs, and eventually you deregister it.
  6. Make sure your device is plugged in, and go to http://deeplens.config/ in your browser. This will let you set up an ssh password.
  7. SSH into the computer and run these commands:
sudo apt-get update
sudo apt-get install awscam
sudo reboot
  1. Register again using V1.1....again....delete IAM roles and randomly keep trying to push through the registration process
  2. Write up a 7 step process document because AWS doesn't seem to care about this service anymore :(
answered 2 years ago
  • AWS has really screwed over anyone who is trying to get a deeplens to work off the shelf. I agree they don't care -- and it sucks.

0

I had same issue, but after enable MFA, then logout and login, it works. Give it a try! :)

wmz
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions