Cannot enable gtid_mode in parameter group

0

I'm on MySQL and trying to enable GTID-based replication with an external source in accordance with the following guide: https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/MySQL.Procedural.Importing.External.Repl.html

I'm running MySQL 8.0.26 and according to the guide, GTID-based replication is possible to achieve for this version. However, step 1b of the guide states "Make sure that the parameter group associated with the DB instance has the following parameter settings: gtid_mode – ON, ON_PERMISSIVE, or OFF_PERMISSIVE", and unfortunately it is not possible to edit gtid_mode in the (custom) parameter group I have assigned to the database instance. Any suggestions on how to solve this issue I'm facing?

Best regards,
Max

Max-Max
asked a year ago169 views
1 Answer
0
Accepted Answer

Hi Max-Max

I understand you’re trying to modify the ‘gtid_mode’ parameter on a custom parameter group of a MySQL8.0 version, but were unable to. I created a custom parameter group on my side for MySQL8.0 version, I then filtered the parameters by typing ‘gtid’ in the search bar, and found two parameters ‘gtid_mode’ (cannot be modified) and ‘gtid-mode’ (can be modified). To solve your issue, you will need to change the parameter values for ‘grid-mode’ instead of ‘gtid_mode’ since.

Please Note:

  • you can verify that a parameter is modifiable by checking if the parameter's property value for “Is Modifiable” is “true”.
  • You also need to set the value of the ‘enforce_gtid_consistency’ parameter to ON, or else you will be prevented from saving any changes made to the ‘gtid_mode’ parameter and receive an error :

Error saving: Having gtid-mode set to ON requires that enforce_gtid_consistency is also set to ON. (Service: AmazonRDS; Status Code: 400; Error Code: InvalidParameterValue; Request ID: bf022269-8eba-4ad6-a620-14d31c39f55e; Proxy: null)

  • The ‘gtid-mode’ and ‘enforce_gtid_consistency’ parameters are both static parameters, this means that in order for the changes to take effect, you will need to reboot your DB instance.

Here is an AWS document that may help in troubleshooting your issue: https://aws.amazon.com/premiumsupport/knowledge-center/rds-modify-parameter-group-values/

I hope this helps

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions