Sage Maker Model Monitor.



I have deployed Mistral 7B LLM model on aws sagemaker using sagemaker studio jumpstart. I have the endpoint with me.

Now I want to know how I can monitor this model using Sagemaker Model Monitor Feature. I am not getting any option on sagemaker console for monitoring. On governance Dashboard nothing is showing except my model endpoint name. Followed some articles and found that by using notebook instance I can configure model monitor feature but getting error.

I am not sure from notebook which example I need to copy and work on that. I need a detail guidance about Sagemaker model Monitor service.

Please help me with this.. Thank you.

1 Answer
  • Go to the SageMaker console and select the 'Model' tab. You should see your model listed here.
  • Select the model and then choose the 'Monitoring' tab. Here you can configure monitoring schedules and view any alerts.
  • For a new model, you may need to wait some time for baseline metrics to be collected before monitoring can be enabled
  • You can set monitoring schedules to check for concept drift at regular intervals. Schedules can be custom frequency like every 6 hours.
  • Alerts will be triggered if the model performance deviates from the baseline by a specified threshold.
  • You can drill down on any alerts to analyze root cause using various plots and metrics provided in SageMaker Studio notebooks.
  • Logs and metrics from the model endpoint are continuously exported to CloudWatch for long term retention and analysis.
profile picture
answered 2 months ago
  • I have mentioned earlier I hosted the LLM model using Sagemaker studio jump start. I did nothing manual configuration at the time of hosting just select the model and click on deploy button. So, after deployment I have the endpoint.

    I checked on the Sagemaker console and found Governance option is there under the Governance - Model Dashboard, I can see my model but there is no option for enabling monitoring service.

    I checked on Sagemaker studio console I can list my endpoint, but no option is there for Monitoring.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions